First cycle off the pill

This being my first cycle off the pill, my cycle is all kinds of screwed up.

I am now on day 33, which is odd for me as I've always been regular, give or take a day... not 5!

I've been charting, as previous mentioned, and I'll get several days of "high temps" and then it'll dip back down below the coverline again. I've several cramping/ovulation pains at different points throughout this cycle.

As is, I'm coming up on a week late with my period, which is strange, as this time a week ago I was displaying a lot of my normal symptoms, including cramping and chocolate cravings. I figure if I don't get it by the end of next week I'll pee on a stick, but I'm not getting my hopes up, as my chart is all over the place and I'm not even sure when I ovulated at this point, that is, if I even ovulated at all!

I asked on the TCOYF forums, linking my chart for this cycle, and the general consensus is, I most likely didn't ovulate, but if I did it was around the 16th, although as of yesturday, the chart itself is saying I ovulated on day 28 (which would mean we missed that boat), but who knows...

Here's a screenie of my current chart for those curious and wanting to take a stab at the "did I ovulate and when?" game (click it to view larger):

Note: the days with X's through them - that means a "disturbance." Days where I didn't get 3 hours of sleep prior to taking my temp count as a disturbance, but I took the temp anyway just to get an idea of where it was at, and of course on Mother's Day I didn't chart, as I had to get up 2 hours prior to the alarm going off, so even taking it wouldn't have been very accurate.

Also, I don't input my cervical fluid daily, so on days it's not marked, it's safe to assume there was nothing.

No comments:

Post a Comment

What's your thoughts?